Spree Commerce

Try It Now

Introducing Rails 2.1 Support

Posted on June 23, 2008 by Sean Schofield

Spree now supports Rails 2.1. This change is effective immediately for all of those working off the latest Github source code. If you are using the gem version of Spree (as opposed to the source) you will have to wait until the upcoming Spree 0.3.0 release. We are also no longer including a frozen version of Rails in the gem (or git repository.) This will cut down on file size considerably. If you require a frozen version of Rails you can add it to your app and/or local check out of the Spree git repository and things will work fine.

We’re still working out the process of how to smoothly upgrade from 0.2.0 deployments. Most likely there aren’t too many of those yet but we intend to make future upgrades as easy as possible so we are doing our best to resolve these issues. Please read the wiki for complete details on how to upgrade your existing application (you can ignore these instructions if you’re starting a new Spree application.) Please report any issues on the spree-user mailing list.