Spree Commerce

Try It Now

Spree 0.5.0 Released

Posted on November 24, 2008 by Sean Schofield

Spree 0.5.0 has officially been released. This version requires Rails 2.1.2. This version will not work with Rails 2.2.2. There are also problems with the spree command used to generate a new application if you have both Rails 2.2.2 and Rails 2.1.2 installed. We’re working on a solution for this but in the meantime, you will need to uninstall Rails 2.2.2. (and all of the dependencies like activesupport) in order for the spree command to work properly.

Highlights of this release include:

  • New and improved shipping framework.
  • Migration generator for extensions
  • Support for sample data in extensions
  • Shipping address limited to the countries that are configured by a shipping zone
  • Configuration screen for inventory settings
  • Built-in mechanism for dealing with near static content
  • Support for requiring/installing gems in extensions
  • Rails 2.1.2 support

The shipping framework represents a major step forward. It provides the ability to customize your application’s shipping logic exactly the way you need it. It also allows for UPS and USPS shipping via the active_shipping extension. For more information see the shipping section in the user’s guide.